lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Mon, 13 May 2024 12:31:29 -0400
From: Luiz Augusto von Dentz <luiz.dentz@...il.com>
To: Kees Cook <keescook@...omium.org>
Cc: Erick Archer <erick.archer@...look.com>, Marcel Holtmann <marcel@...tmann.org>, 
	Johan Hedberg <johan.hedberg@...il.com>, "David S. Miller" <davem@...emloft.net>, 
	Eric Dumazet <edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>, 
	"Gustavo A. R. Silva" <gustavoars@...nel.org>, Nathan Chancellor <nathan@...nel.org>, 
	Nick Desaulniers <ndesaulniers@...gle.com>, Bill Wendling <morbo@...gle.com>, 
	Justin Stitt <justinstitt@...gle.com>, linux-bluetooth@...r.kernel.org, 
	netdev@...r.kernel.org, linux-kernel@...r.kernel.org, 
	linux-hardening@...r.kernel.org, llvm@...ts.linux.dev
Subject: Re: [PATCH] Bluetooth: hci_core: Prefer struct_size over open coded arithmetic

Hi Eric,

On Sun, May 12, 2024 at 11:08 PM Kees Cook <keescook@...omium.org> wrote:
>
> On Sun, May 12, 2024 at 04:17:06PM +0200, Erick Archer wrote:
> > This is an effort to get rid of all multiplications from allocation
> > functions in order to prevent integer overflows [1][2].
> >
> > As the "dl" variable is a pointer to "struct hci_dev_list_req" and this
> > structure ends in a flexible array:
> >
> > struct hci_dev_list_req {
> >       [...]
> >       struct hci_dev_req dev_req[];   /* hci_dev_req structures */
> > };
> >
> > the preferred way in the kernel is to use the struct_size() helper to
> > do the arithmetic instead of the calculation "size + count * size" in
> > the kzalloc() and copy_to_user() functions.
> >
> > At the same time, prepare for the coming implementation by GCC and Clang
> > of the __counted_by attribute. Flexible array members annotated with
> > __counted_by can have their accesses bounds-checked at run-time via
> > CONFIG_UBSAN_BOUNDS (for array indexing) and CONFIG_FORTIFY_SOURCE (for
> > strcpy/memcpy-family functions).
> >
> > In this case, it is important to note that the logic needs a little
> > refactoring to ensure that the "dev_num" member is initialized before
> > the first access to the flex array. Specifically, add the assignment
> > before the list_for_each_entry() loop.
> >
> > Also remove the "size" variable as it is no longer needed and refactor
> > the list_for_each_entry() loop to use dr[n] instead of (dr + n).

Have the change above split on its own patch.

> > This way, the code is more readable, idiomatic and safer.
> >
> > This code was detected with the help of Coccinelle, and audited and
> > modified manually.
> >
> > Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> > Link: https://github.com/KSPP/linux/issues/160 [2]
> >
> > Signed-off-by: Erick Archer <erick.archer@...look.com>
>
> Looks right to me. Thanks!
>
> Reviewed-by: Kees Cook <keescook@...omium.org>
>
> --
> Kees Cook



-- 
Luiz Augusto von Dentz

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ